The recent version of Flash10 browser plugin is not compatible with some of the older flash tools and websites. 

If you are experiencing problems with website after installing the Flash10 Plugin (particluarly with uploader tools), try downgrading to an older version of flash.

To do this,

1) Download the Flash Unistaller found here

2) Close all browsers first and run the unistaller.

3) Download Flash 9 from here and install teh IE or firefox plugin: